Drupal 9 的环境要求

hrs 提交于 2022/05/16 - 01:22 , 周一

Nginx 版本要求
如果您在 Nginx 上运行 Drupal 9,则至少需要 0.7.x 版本。

Apache 版本要求
如果您在 Apache 上运行 Drupal 9,则至少需要 2.4.7 版本。

PHP版本要求
Drupal 9 至少需要 PHP 7.3。PHP 7.4 也受支持,但不是必需的。Drupal 9.1.0 支持 PHP 8

数据库后端和其他托管要求
如果将 Drupal 9 与 MySQL 或 Percona 一起使用,则需要 5.7.8+ 版本。
如果将 Drupal 9 与 MariaDB 一起使用,则需要 10.3.7+ 版本。
如果将 Drupal 9 与 SQLite 一起使用,则需要 3.26+ 版本。(PHP 7.4 不使用系统提供的 SQLite,因此请特别注意确保您的 PHP 至少使用此版本编译)。
如果将 Drupal 9 与 PostgreSQL 一起使用,则需要 pg_trgm 扩展的版本 10。 
关于 Drush 的说明
虽然 Drupal 核心不需要 Drush,但许多人确实使用 Drush。有关受支持版本的信息,请参阅 Drush 版本兼容性页面 。

标签